Alert: Batching Notification
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the batching delay issue. All batching operations have returned to normal.
Posted Oct 18, 2022 - 21:45 EDT
Monitoring
FreedomPay continues to remediate additional reports of some erroneous transactions, and is working diligently to remediate any outstanding consumer impact. For questions or support, please contact techsupport@freedompay.com.
Posted Sep 21, 2022 - 13:51 EDT
This incident affected: Batching.