Alert: Fiserv Nashville - US (Omnichannel) Transaction Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Fiserv Nashville - US relationship manager.
Posted Mar 24, 2025 - 13:51 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Fiserv Nashville - US. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Mar 24, 2025 - 13:25 EDT
This incident affected: Processors (FreeWay Offramps) (Fiserv Nashville - US (Omnichannel)).