Alert: FEXCO Dynamic Currency Conversion Transaction Processing Latency
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted May 30, 2023 - 04:23 EDT
Identified
FreedomPay has identified the issue causing transaction processing latency with FEXCO Dynamic Currency Conversion.  FreedomPay's Incident Response team is currently addressing the issue and will update clients once the issue has been resolved.
Posted May 30, 2023 - 02:56 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency with FEXCO Dynamic Currency Conversion.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted May 29, 2023 - 23:59 EDT
This incident affected: Dynamic Currency Conversion (DCC) Providers (FEXCO (DCC)).