RedSys ISO - Degraded performance

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Redsys - Europe relationship manager.
Posted Jan 13, 2026 - 01:22 EST

Investigating

We are currently investigating this issue.
Posted Jan 13, 2026 - 01:15 EST
This incident affected: Processors (Redsys - Europe).