Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Lloyds Bank Cardnet - Fiserv MSIP - UK relationship manager.
Posted Aug 12, 2025 - 03:13 EDT
Update
FreedomPay is currently investigating reports of transaction processing latency and timeouts with Lloyds Bank Cardnet - Fiserv MSIP - UK. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Aug 12, 2025 - 03:06 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with Lloyds Bank Cardnet - Fiserv MSIP - UK. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Aug 12, 2025 - 03:00 EDT
This incident affected: Processors (Lloyds Bank Cardnet - Fiserv OmniPay - UK).