Alert: CNH Transaction Processing Issues
Incident Report for FreedomPay
Resolved
Transaction processing has returned to normal and all issues have been resolved.  For questions or comments, please contact your CNH relationship manager.
Posted May 20, 2023 - 23:06 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with CNH. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted May 20, 2023 - 21:08 EDT
This incident affected: Processors (FreeWay Offramps) (CNH).