Alert: 3D Secure Transaction Processing Issues
Incident Report for FreedomPay
Resolved
3D Secure transaction processing has returned to normal and all issues have been resolved.
Posted Jun 21, 2022 - 04:09 EDT
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 03:13 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with our 3D Secure provider. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients
Posted Jun 21, 2022 - 03:13 EDT
This incident affected: FreeWay, Hosted Payment Page (eCommerce), Hosted Payment Controls, 3D Secure, and Fraud Detection.