Resolved: Fiserv Nashville - US (Omnichannel) - Transaction Processing Latency

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Fiserv Nashville - US (Omnichannel) relationship manager.
Posted May 03, 2025 - 16:03 EDT
This incident affected: Processors (Fiserv Nashville - US).