Alert: Global Blue - Currency Select - Australia Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Global Blue - Currency Select - Australia relationship manager.
Posted Jul 08, 2025 - 23:50 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Global Blue - Currency Select - Australia. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Jul 08, 2025 - 20:44 EDT
This incident affected: Processors (Global Blue - Currency Select - Australia).