Alert: RedSys Transaction Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved.  For questions or comments, please contact your RedSys relationship manager.
Posted Mar 24, 2025 - 19:53 EDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 19:52 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with RedSys. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Mar 24, 2025 - 19:40 EDT
This incident affected: Processors (FreeWay Offramps) (RedSys).