Alert: Asset Management API Transaction Processing Latency

Incident Report for FreedomPay

Resolved

FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Apr 17, 2025 - 01:12 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency with Asset Management API.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Apr 17, 2025 - 00:41 EDT
This incident affected: Web Portals (Asset Management API).