Alert: Heartland Transaction Processing Issues
Incident Report for FreedomPay
Resolved
Transaction processing has returned to normal and all issues have been resolved.  For questions or comments, please contact your Heartland relationship manager.
Posted May 19, 2023 - 21:08 EDT
Monitoring
FreedomPay is in contact with Heartland, and is continuing to monitor transaction latency and processing timeouts.  We will provide an update to our clients once the issue has been resolved.
Posted May 19, 2023 - 21:03 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with Heartland. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted May 19, 2023 - 20:54 EDT
This incident affected: Processors (FreeWay Offramps) (Heartland).