Alert: UAT Environment Performance Degradation

Incident Report for FreedomPay

Resolved

FreedomPay has resolved the of performance degradation with FreedomPay's UAT environment and all transaction processing has returned to normal.
Posted 10 days ago. Mar 25, 2025 - 09:22 EDT

Investigating

FreedomPay is currently investigating reports of performance degradation with FreedomPay's UAT environment. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted 10 days ago. Mar 25, 2025 - 08:11 EDT
This incident affected: UAT.