Alert: Freeway Transaction Processing Latency

Incident Report for FreedomPay

Resolved

FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Dec 09, 2022 - 13:12 EST

Investigating

FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Dec 09, 2022 - 12:23 EST
This incident affected: FreeWay.