Completed
The scheduled maintenance has been completed.
Posted Jun 29, 2022 - 05:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2022 - 03:00 EDT
Scheduled
DATE: Wednesday, June 29th
MAINTENANCE WINDOW: Wednesday: 3 AM to 5 AM EDT // 0700 to 0900 UTC
MAINTENANCE DESCRIPTION:
FreedomPay will be performing system maintenance starting at 3 AM and ending by 5 AM EDT (0700 to 0900 UTC).
MAINTENANCE IMPACT:
During the maintenance window there may be intermittent transaction timeouts lasting 1-2 minutes each over a 30 minute time period. During this time period if you receive a timeout please reattempt your transaction.
FreedomPay has taken every appropriate measure to minimize the impact of this maintenance, and does not foresee any ongoing issues as a result of changes to be made.
Posted Jun 24, 2022 - 15:19 EDT
This scheduled maintenance affected: Freeway, Hosted FCC, Value Added Services Engine (VAS), Gift Card Processors (Ceridian SVS, Givex, Heartland Gift Card, ValueLink, Worldpay Gift Card US, Worldpay Vantiv - Mercury Gift Cards), Dynamic Currency Conversion (DCC) Providers (FEXCO, Planet Payments), Processors (AMEX Direct, Barclays Payments Europe, Chase Payment Services - Stratus - Global, De Lange Landen Processing Platform, Elavon Europe, Elavon US and Canada, Fiserv Nashville - US, Global Payments East - US, Global Payments Heartland - US, Global Payments TSYS - US, Lloyds Bank Cardnet - Fiserv MSIP - UK, Lloyds Bank Cardnet - Fiserv OmniPay - UK, Visa Acceptance Platform (VAP), Worldpay, Worldpay Vantiv), eCommerce Services (Hosted Payment Controls, Hosted Payment Page), Web Portals (Device Management Portal, Enterprise Portal), and Token Services (Payment Information Proxy Service).