Resolved: Hosted Payment Controls Transaction Processing Latency
Incident Report for FreedomPay
Resolved
FreedomPay has identified the issue causing transaction processing latency with Hosted Payment Controls.  FreedomPay's Incident Response team is currently addressing the issue and will update clients once the issue has been resolved.

FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Sep 10, 2024 - 11:50 EDT