Alert: Elavon Transaction Processing Issues
Incident Report for FreedomPay
Resolved
Transaction processing has returned to normal and all issues have been resolved.  For questions or comments, please contact your Elavon relationship manager.
Posted Feb 05, 2023 - 07:19 EST
Update
Elavon is finishing their maintenance soon:

Good Morning,

We are currently performing maintenance under CHG0409510. This change window is from 12:30 AM to 07:00 AM ET.

Kind Regards,
Stephanie M. Jordan
Network Ops Center Admin
p. 865-403-8663 | stephanie.jordan@elavon.com
Posted Feb 05, 2023 - 06:30 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with Elavon. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Feb 05, 2023 - 06:28 EST
This incident affected: Processors (FreeWay Offramps) (Elavon).