Alert: Chase Paymentech Transaction Processing Issues
Incident Report for FreedomPay
Resolved
Transaction processing has returned to normal and all issues have been resolved.  For questions or comments, please contact your Chase Paymentech relationship manager.
Posted Dec 02, 2024 - 09:59 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with Chase Paymentech. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Dec 02, 2024 - 09:31 EST
This incident affected: Processors (FreeWay Offramps) (Chase Paymentech).