Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2025 - 03:00 EDT
Scheduled
DATE: Wednesday, June 18th
MAINTENANCE WINDOW: Wednesday: 3 AM to 5 AM EDT // 0700 to 0900 UTC
MAINTENANCE DESCRIPTION: FreedomPay will be performing system maintenance starting at 3 AM and ending by 5 AM EDT (0700 to 0900 UTC).
MAINTENANCE IMPACT:
During the maintenance window there may be intermittent transaction timeouts lasting 1-2 minutes each over a 30 minute time period. Tokenization services will also be undergoing a system upgrade and customers may experience timeouts related to token requests or transactions, lasting 3-5 minutes. During this time period if you receive a timeout, please reattempt your transaction.
FreedomPay has taken every appropriate measure to minimize the impact of this maintenance, and does not foresee any ongoing issues as a result of changes to be made.
Posted Jun 13, 2025 - 11:01 EDT
This scheduled maintenance affected: Token Services (FreedomPay Tokenization).