Alert: Visa Cardinal Commerce 3D Secure Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved.
Posted Dec 05, 2025 - 04:19 EST

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Visa Cardinal Commerce 3D Secure. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Dec 05, 2025 - 04:02 EST
This incident affected: Freeway, eCommerce Services (Hosted Payment Controls, Hosted Payment Page, HPX), and 3D Secure Providers (Visa Cardinal Commerce 3D Secure).