Alert: Lloyds Bank Cardnet - Fiserv OmniPay - UK Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Lloyds Bank Cardnet - Fiserv OmniPay - UK relationship manager.
Posted Jul 06, 2025 - 01:28 EDT

Update

We are continuing to investigate this issue.
Posted Jul 06, 2025 - 01:27 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Lloyds Bank Cardnet - Fiserv OmniPay - UK. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Jul 06, 2025 - 00:59 EDT
This incident affected: Processors (Lloyds Bank Cardnet - Fiserv OmniPay - UK).