Alert: Stored Value Transaction Processing Latency
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Apr 21, 2024 - 05:05 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Stored Value.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Apr 21, 2024 - 04:53 EDT
This incident affected: Stored Value.