Alert: 3D Secure Transaction Processing Issues
Incident Report for FreedomPay
Resolved
3D Secure transaction processing has returned to normal and all issues have been resolved.
Posted Nov 30, 2022 - 09:16 EST
Update
Mastercard has reported an increase in latency and connectivity issues today that have led to an increase in Directory Server timeouts causing Lookup/Enrollment messages to result in Enrollment Status = U or B.

Start Time: 30-Nov-2022 08:25 GMT

By 10:10 GMT, the vast majority of these timeouts have subsided. The only remaining impact is specifically for 3DS 1.0 traffic in the India region.

Cardinal engineers have been actively engaged with Mastercard throughout this impact window. Mastercard is aware and working on a resolution. They do not have an ETA on a fix at this time, but we will continue to communicate updates from their team as we receive them.
Please let us know if you have any questions or concerns at this time.
Posted Nov 30, 2022 - 06:20 EST
Monitoring
Mastercard is reporting to us that all major markets outside of India should have seen a majority of transaction impact come to an end. Mastercard has informed Cardinal that all of their requisite teams are presently engaged with the issue, and are working towards full restoration of services. As of 5:23 EST, they have no ETA for when this will be accomplished. We will continue to communicate with them closely and provide updates as we have them
Posted Nov 30, 2022 - 05:54 EST
Update
Mastercard has restored services in many major markets, though we are still monitoring significant impact in the India market.

Cardinal is continuing to work with Mastercard to determine if the situation is now fully restored, or if further fixes are required. Thank you for your patience.
Posted Nov 30, 2022 - 04:52 EST
Update
Cardinal can confirm the outage issue began at 30-Nov-2022, at 8:25 GMT.

Mastercard is reporting some restoration to services in some regions. The issue is still under investigation, no root cause has been determined, and they are still working to reach a full restoration of services.

We will continue to monitor and communicate with Mastercard, and with you, in order to ensure the swiftest resolution to the issue.
Posted Nov 30, 2022 - 04:32 EST
Update
From Cardinal:
Mastercard Securecode has confirmed that they have turned off all 3D Secure processing for Mastercard transactions. This is impacting all transactions across VCAS and Centinel systems. At this time, Cardinal is in close contact with Mastercard, who are working to correct the issue. We will be providing regular updates to this issue as we receive them, and are continuing to track impacts to Cardinal customers.
Posted Nov 30, 2022 - 04:10 EST
Update
Cardinal is having some issues on their end
Confirmed by their status page
https://cardinalcommercecorporation.statuspage.io/
Investigating - Cardinal monitoring has detected intermittent issues processing consumer authentication (3DS) transactions with Mastercard Secure Code. We are investigating the cause and working urgently to resolve the issue.
Posted Nov 30, 2022 - 04:04 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with our 3D Secure provider. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients
Posted Nov 30, 2022 - 04:03 EST
This incident affected: FreeWay, Hosted Payment Page (eCommerce), and Hosted Payment Controls.