Alert: Cloud Middleware Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved.
Posted Jun 09, 2025 - 10:19 EDT

Monitoring

FreedomPay has identified the issue causing transaction processing latency with Cloud Middleware.  FreedomPay's Incident Response team is currently addressing the issue and will update clients once the issue has been resolved.
Posted Jun 09, 2025 - 08:04 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Cloud Middleware. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Jun 09, 2025 - 06:29 EDT
This incident affected: Cloud Middleware.