Chase Paymentech – Monitoring

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved.
Posted Nov 24, 2023 - 21:13 EST

Update

FreedomPay is experiencing latency with Chase issued card brands and is continuing to monitor.  FreedomPay is in contact with Chase and will provide an update to our clients, once the issue has been resolved.
Posted Nov 24, 2023 - 15:56 EST

Monitoring

FreedomPay is in contact with Chase Paymentech, and is continuing to monitor transaction latency and processing timeouts.  We will provide an update to our clients once the issue has been resolved.
Posted Nov 24, 2023 - 15:32 EST
This incident affected: Processors (FreeWay Offramps) (Fiserv Nashville - US (Omnichannel), Vantiv (WorldPay - US/CA), TSYS, Global Payments, Heartland, WorldPay, Chase Paymentech, Elavon, Elavon U.K., Barclaycard (U.K.), AMEX Direct, Visa ACP, AGCO, Lloyds OmniPay, Lloyds MSIP, Currency Select, CNH, WPG (WorldPay), RedSys).