Alert: Enterprise Portal Reporting Delays

Incident Report for FreedomPay

Resolved

Enterprise Portal reporting delays have been fully resolved.
Posted Jan 31, 2025 - 05:22 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2025 - 05:17 EST

Investigating

FreedomPay is currently investigating reports of reporting delays with Enterprise Portal. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Jan 31, 2025 - 05:07 EST
This incident affected: Web Portals (Enterprise Portal).