Alert: Freeway Transaction Processing Latency
Incident Report for FreedomPay
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 05:55 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 05:51 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Nov 06, 2024 - 05:49 EST
This incident affected: FreeWay.