Alert: Freeway Transaction Processing Latency
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Mar 27, 2023 - 14:30 EDT
Update
FreedomPay's Technical Team is continuing to investigate possible latency in transactions.  We will continue to update the status of this page as updates become available.
Posted Mar 27, 2023 - 13:50 EDT
Update
FreedomPay's Technical Team is continuing to investigate possible latency in transactions.  We will continue to update the status of this page as updates become available.
Posted Mar 27, 2023 - 13:11 EDT
Update
FreedomPay's Technical Team is further investigating possible latency in transactions.  We will continue to update the status of this page as new information comes in.
Posted Mar 27, 2023 - 12:53 EDT
Update
FreedomPay's Incident response team is further investigating possible latency in transactions and will send updates as information comes in.
Posted Mar 27, 2023 - 12:36 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Mar 27, 2023 - 12:11 EDT
This incident affected: FreeWay.