Alert: Kount Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved.
Posted Dec 05, 2025 - 04:20 EST

Monitoring

FreedomPay is in contact with Kount and is continuing to monitor transaction latency and processing timeouts. We will provided an update to our clients once the issue has been resolved.
Posted Dec 05, 2025 - 04:18 EST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 04:17 EST

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Kount. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Dec 05, 2025 - 04:03 EST
This incident affected: Fraud Detection Providers (Kount).