Alert: Freeway Transaction Processing Latency
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Sep 19, 2022 - 01:37 EDT
Update
We are continuing to investigate reports of latency following the hotfix. Support teams are engaged and an update will be provided as soon as possible. If you have questions or need support, please contact us at techsupport@freedompay.com.
Posted Sep 19, 2022 - 00:11 EDT
Monitoring
The hotfix has been deployed successfully. Clients can expect to see transaction processing return to normal performance levels over the next hour. If you have questions or need support, please contact us at techsupport@freedompay.com.
Posted Sep 18, 2022 - 22:08 EDT
Update
We are working on implementing a hotfix which we expect to resolve the issue. We will provide an update in 30 minutes. For support with offline mode, please contact techsupport@freedompay.com and a technician will assist.
Posted Sep 18, 2022 - 20:57 EDT
Update
We are still experiencing high latency following failover and are continuing to investigate root cause. We will provide an update in 30 minutes. For support with offline mode, please contact techsupport@freedompay.com and a technician will assist.
Posted Sep 18, 2022 - 20:12 EDT
Identified
Our teams have identified the root cause, and anticipate the issue to be fully remediated within 60 minutes or less.
Posted Sep 18, 2022 - 18:42 EDT
Update
Transaction processing is stabilizing but we are still experiencing latency and timeouts. Our technical teams are aggressively engaged in troubleshooting, and our support teams are available for assistance with offline mode by contacting techsupport@freedompay.com. We will provide any additional updates ASAP.
Posted Sep 18, 2022 - 17:35 EDT
Update
FreeWay is still experiencing high latency processing transactions. All technical teams are actively engaged in troubleshooting to resolve ASAP. We will continue to provide updates as we have additional information.
Posted Sep 18, 2022 - 16:07 EDT
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Sep 18, 2022 - 14:41 EDT
This incident affected: FreeWay.