Alert: Value Added Services Engine Transaction Processing Latency

Incident Report for FreedomPay

Resolved

FreedomPay has resolved the issues on Value Added Services and all transaction processing has returned to normal.
Posted Dec 04, 2023 - 10:15 EST

Investigating

FreedomPay is currently investigating reports of issues with Value Added Services Engine. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Dec 04, 2023 - 09:36 EST
This incident affected: Value Added Services Engine (VAS).