Alert: Fiserv Nashville - US Processing Issues

Incident Report for FreedomPay

Resolved

Transaction processing has returned to normal and all issues have been resolved. For questions or comments, please contact your Fiserv Nashville - US relationship manager.
Posted Jun 14, 2025 - 12:30 EDT

Monitoring

FreedomPay is in contact with Fiserv Nashville - US and is continuing to monitor transaction latency and processing timeouts. We will provided an update to our clients once the issue has been resolved.
Posted Jun 14, 2025 - 11:52 EDT

Investigating

FreedomPay is currently investigating reports of transaction processing latency and timeouts with Fiserv Nashville - US. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Jun 14, 2025 - 11:09 EDT
This incident affected: Processors (Fiserv Nashville - US).