Alert: Batching Delays
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the batching delay issue. All batching operations have returned to normal.
Posted Sep 20, 2022 - 18:53 EDT
Update
FreedomPay has started releasing batches over the past 5 hours. Our Incident Response Team is continuing to work through the release of remaining batches. We apologize for the inconvenience. Please contact technical support with any additional questions at techsupport@freedompay.com.
Posted Sep 20, 2022 - 14:11 EDT
Identified
FreedomPay will be delaying batching for up to 24 hours. We apologize for the inconvenience. Please contact your account manager or technical support with any questions.
Posted Sep 19, 2022 - 01:45 EDT
This incident affected: Batching.