Alert: Enterprise Portal Transaction Processing Latency
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Feb 05, 2023 - 09:17 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Enterprise Portal.  FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Feb 05, 2023 - 06:27 EST
This incident affected: Web Portals (Enterprise Portal).