Alert: First Data (Nashville) Transaction Processing Issues
Incident Report for FreedomPay
Resolved
Transaction processing has returned to normal and all issues have been resolved.
Posted Feb 06, 2023 - 17:16 EST
Update
The Discover Network continues to experience issues but transaction processing is stabilizing.  We will continue to monitor and provide updates as new information becomes available.
Posted Feb 06, 2023 - 17:01 EST
Update
There are no additional updates at this time. We will continue to update the status page as more information becomes available.
Posted Feb 06, 2023 - 16:46 EST
Update
Discover Network continues to experience an outage and it has been reported that the upstream issues may be impacting other card types. We will continue to provide updates as they become available.
Posted Feb 06, 2023 - 16:32 EST
Update
Discover Network is experiencing an outage that may be impacting the ability to process transactions for Discover, JCB, and Diners cards. Discover Network is working to restore service.
Posted Feb 06, 2023 - 16:17 EST
Update
Customers are continuing to experience issues using Discover-issued cards due to an upstream issue. Operators should direct customers to utilize other card types where possible.  We will continue to provide updates as more information becomes available.
Posted Feb 06, 2023 - 16:01 EST
Identified
The issue has been identified as an upstream issue with Discover. FreedomPay teams are continuing to work with processors to resolve the issue.
Posted Feb 06, 2023 - 15:50 EST
Update
There are no additional updates at this time. FreedomPay is continuing to investigate the issue impacting Fiserv merchants.
Posted Feb 06, 2023 - 15:33 EST
Update
FreedomPay is communicating with Fiserv to understand the impact of the issue, root cause and remediation timeline.  We will continue to provide updates as additional information becomes available.
Posted Feb 06, 2023 - 15:18 EST
Update
FreedomPay is continuing to investigate reports of transaction processing latency and timeouts with First Data Nashville. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Feb 06, 2023 - 15:00 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with First Data Nashville. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Feb 06, 2023 - 14:38 EST
This incident affected: Processors (FreeWay Offramps) (First Data).