Alert: TSYS Transaction Processing Issues
Incident Report for FreedomPay
Resolved
Transaction processing has returned to normal and all issues have been resolved.  For questions or comments, please contact your Heartland relationship manager.
Posted Feb 07, 2023 - 06:05 EST
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with TSYS and Heartland. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients.
Posted Feb 07, 2023 - 04:54 EST
This incident affected: FreeWay and Processors (FreeWay Offramps) (TSYS, Heartland).