Alert: Batching Delays
Incident Report for FreedomPay
Resolved
FreedomPay has resolved the batching delay issue. All batching operations have returned to normal.
Posted Sep 16, 2022 - 08:48 EDT
Investigating
FreedomPay is currently investigating settlement file transmission delays with OmniPay. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they are available.
Posted Sep 15, 2022 - 16:16 EDT
This incident affected: Batching.